20

November
2017

Is there malware in Chromium in Slax?

Several people complained that I've added malware to chromium in Slax, and similar shit :) So, lets take a look at it.

The chromium module in Slax is created using this method:
1) boot fresh Slax
2) apt install chromium
3) savechanges /04-chromium.sb

That is all. Well, the procedure is indeed a little bit more complicated since I want to remove some unneded files after apt install, and I need to provide a 'chromium' script which logins as guest user and starts the chromium binary, because chromium refuses to run as root, but other than that, I make no changes. Especially I add no chromium extensions etc. You can review the build script here

If you start chromium in Slax and check out chrome://extensions URL, you will indeed see three extensions. Those cannot be disabled or uninstalled through the settings interface. What are those extensions? Well I have no idea what they do, but you can gues by their names:

- bookmark manager
- pdf viewer
- cryptoTokenExtension

To be honest, I didn't know that chromium installed with apt install has such extensions. I am not sure if all of them are really needed. But as I mentioned, I am not adding these, if you install fresh Debian and you install chromium the way I did, you'll get those extensions too. I believe that Debian developers know what they are doing, and I doubt those extensions would be any harmful.

I can assure you that if I was to add malware to chromium in Slax, I would definitely add it in a way that you could never notice. Adding malware this way makes no sense :-)

User comments
lucbertz 2017-11-20 11:51

Your last sentence frighten me.

Anyway, if I want to remove Chromium and add SeaMonkey to a customized SLAX iso, can I simply proceed in the following way?

- remove 04-chromium.sb file
- install seamonkey
- savechanges /04-seamonkey.sb
- rebuild iso

Otherwise can you tell us how to create modules starting from Debian packages?

Tomas M 2017-11-20 13:43

Yep, this is it, just remove 04-chromium and install whatever you like.
I think I'll create a special page to describe how to make modules from installed software. It's really easy. You just boot fresh, apt install everything, then run savechanges, and finally store the module in your Slax

Ferenc 2017-11-20 14:48

Hi Tomas
I'm trying to install slax into a kvm image (using virt-manager), but i have difficulties.

I'm using the slax-64bit-9.2.1.iso and the KVM virtul machine settings are the following:
- 2 GB RAM
- 2 cores
- 1GB HDD using SATA interface (tried with Virtio with the same results)

Things i've done:
- I've formatted the hdd to ext4 using gparted
- i've copied over the /slax directory using mc

When i start the VM i get the following error message:
Looking for slax data in /slax ......................
Fatal error occurred - Could not locate slax data

I've /slax/changes on sda1 and i made them writable, still i do not seem to be able to boot the system from sda1 with or without persistent changes.

Eddie WatNou 2017-11-20 16:12

Next to savechanges there is also the slax, dir2sb and sb2dir commands.

I tried creating a module the hard way with apt--download-only install packagename and extracting the packages with dpkg-deb x. But that will not run the install scripts.
But maybe someone will find this info usefull.

An explanation about creating modules would be very usefull.

The system seems to be very stable. And i love the modular way to add and remove applications/libraries.

I really love this system already

Eddie WatNou 2017-11-20 16:14

I have not yet taken a look at the slax script but can you run a script on module activation?? So you can add users, update configs, etc...

Russell Hernandez 2017-11-20 21:18

I think chromium should not be default simply because if one has internet to use a browser they can simply `apt install browser`, so I rather save myself the megabytes :). However, when that module blog is posted this won't matter so much, so I'll be waiting.

Ferenc 2017-11-21 00:02

Well kind of managed to get persistent changes working with virt-manager.
I had to use fat32 filesystem on a virtual disk that was connected on IDE bus.

Strange that it did not work with ext4 file system..

Killy 2017-11-21 01:15

> I think I'll create a special page to describe how to make modules from installed software.

Modules IS the thing that makes Slax useful and makes it stand out from "live-cd" type distros. This better be published asap and in detail, and also promoted as the main feature. People should know why Slax is so awesome and when it is irreplaceable.

Pavel Bohmat 2017-11-21 21:03

chrome://settings and menu invisible in chromium62 :(
manual module, remade your or Apt

see https://goo.gl/zqBktf

Ferenc 2017-11-21 21:04

persistence works on ext3 filesystem, but it does not on ext4

Pavel Bohmat 2017-11-22 09:09

He is alive! :)04-chromium62.sb v. 62.0.3202.8 https://cloud.mail.ru/public/2Kyr/QzNoEUcJw

how to remove, where is the pre-installed garbage ext?

lucbertz 2017-11-22 10:58

I confirm I was able to boot with ext3.

With ext4 and NTFS boot sticks on:
"Looking for slax data in /slax ..............."

Furthermore I had to manually install ntfs-3g in order to get writing functionality on NTFS disks.

This release of Slax is not for newbies like the previous ones.

Guilherme Mendes 2017-11-23 17:21

"since I want to remove some unneded files after apt install"
you should use this option when installing to get the least packages possible "--no-install-recommends"

Guilherme Mendes 2017-11-23 17:28

Tomas, I'm just a noob but I might have a very good tip. Do you start the process of building Slax by installing Debian in a normal way and then configuring it? If yes, you can skip one step in the minimal installation that gather a lot of non essential packages and might save precious megabytes. I remember doing my minimal installations and skipping it would result in a much smaller system.

Non Omnis Moriar 2017-11-24 09:15

I have a question ...

I would like to remaster SLAX in that way :

1. Installing atari 8bit emulator
2. Remastering iso adding roms, game files etc...
3 . Making the Atari emulator automatically start after booting SLAX

and heres the question ... How can i make autostart program afters staring X and fluxbox ??

Pavel Bohmat 2017-11-24 12:30

>How autostart program afters staring fluxbox?
add in /root/.fluxbox/startup

Non Omnis Moriar 2017-11-24 13:46

Hi Pavel Bohmat,

I checked the script you wrote about ... but there is problem...

The last command in this script is : exec fluxbox

So i added next command to this script . Simply : /usr/bin/atari800

and it didnt start anyway.

I struggle two days with such simple thing as setting an installed program to run automatic after system is completly loaded...

Non Omnis Moriar 2017-11-24 14:15

Ok ... Got it ! Everything works now ... Everything was in fluxbox wiki .

Many thanks Pavel Bohmat for your advice !

Za Xandros 2017-11-25 12:21

@Tomas M:
Kindly in your upcoming article, also mention about how to "rebuildiso" (after running savechanges /04-seamonkey.sb) , as @lucbertz has mentioned in the comment above.

Juan De Abajo 2017-11-25 20:01

I've packed also Palemoon and google chrome browsers for slax. I find that couldn't set a proxy for chromium, so installed chrome. It couldn't set a proxy either, so installed palemoon. Both browsers had dependencies out of the stable Debian branch, so I used some required packets from Sparkylinux repo (https://sparkylinux.org/), adapted to run on stretch. Many thanx to sparkylinux developers, as both browsers working like a charm on slax.

Juan De Abajo 2017-11-25 20:09

But:
Dont replace chromium just for the proxy settings. You can set a proxy for your chromium session running the command:
chromium --proxy-server="proxy.server.orc:3128"
or make a custom javascript .pac script and run:
chromium --proxy-pac-url="file:///root/proxy.pac"

Harlley Guimarães 2017-12-03 01:46

Hi! I'm new to Slax and Linux in general and followed the steps to install the system on a Sony flash drive stick, to no avail. I choose the flash drive as first boot device and get a "no default or UI config found" error message. Any sugestion?