02

July
2013

Slax 7.0.9 beta release

Hello everybody. After few months of silence, the Beta release of Slax 7.0.9 is now available for testing. It features Linux Kernel 3.9.7, KDE 4.10.4 and FireFox 22.0. It is a bit bigger than usual, since FireFox started to require icu4c for some strange reason, which is 7MB packed (!) ... I have to find out if this dependency can be dropped.

In the mean time, please feel free to test this beta release and let me know if you recognize anything unusual. Your feedback will help make Slax better. Thank you very much for using Slax! :)

Download Slax 7.0.9-beta:
32bit ISO
32bit ZIP
64bit ISO
64bit ZIP

User comments
MonkeyGuys Scotty 2013-07-02 07:50

Already found some problems : For some reason, when i create a new taskbar, and remove the old one there was a calendar floating on my desktop, and whenever i opened that one on my taskbar, it kind of broke the graphics... Also, some of the animations are broken : Log out goes suddenly to white, Turning off - The graphics gone a bit wrong. But those are just small bugs you can fix later :) you can go on developement and fix those later, it is not a very big problem, just animations :)

Tomas M 2013-07-02 08:05

Actually I'm not the one who could fix those, ... but I will definitely have a look and fill a bug report to KDE team if I can reproduce it here. Thank you very much.

Internet Only 2013-07-02 12:02

CHANGELOG file is not updated properly.
Where can we find module for kernel-source-3.9.7.sb ???...

Mahmoud 2013-07-02 12:10

Wonderful! I haven't updated since 7.0.5. but I will definitely update to 7.0.9.!
Slax is a great little OS, by the way. Privately, I use it around 80-90% of the time. The other 10-20% being Windows 7.

Jonathan Vasquez 2013-07-02 14:03

Hey Thomas,

Where can I contact you (email if possible) so I can discuss some development that I'm doing on Funtoo by using SLAX?

I've switched Funtoo's (Improved Gentoo by Daniel Robbins - Gentoo Creator) ZFS Install media from System Rescue CD (I was using my own System Rescue Modules which use AUFS) to SLAX since you also use AUFS and you actually use a pretty vanilla architecture which I very much like.

If you visit the guide I wrote for installing Funtoo on ZFS, you will notice that I'm using a slightly modified version of SLAX with Native ZFS modules included with a recompiled kernel (Your kernel doesn't support AMD's IOMMU and also has HID compiled as modules rather than built in. This causes problems with people who have motherboards that use IOMMU on 64 bit kernels. Basically the problem is that the USB devices aren't mapped properly to memory without IOMMU and thus all USB devices connected to USB 2.0 ports that depend on IOMMU for remapping are unusable).

Guide below (With video):
http://www.funtoo.org/wiki/ZFS_Install_Guide

Changes between my kernel and yours:
http://ftp.osuosl.org/pub/funtoo/distfiles/bliss-kernel/3.9.8-FB.03/CHANGES-3.9.8-FB.03

my email address is jvasquez1011@gmail.com

Sorry that I'm posting this here btw, I didn't know where else to contact you. I would have just emailed you.

- Jonathan

MonkeyGuys Scotty 2013-07-02 16:44

Looking for some bugs...

I have a problem while changing resolution, it keeps on 800x600 but Slax just resizes the pixels, i had this problem even in the older versions, i would be happy if there was a fix :) however, there is not any resolution problem while running on a virtual machine.

Also, when i have changed the resolution, the taskbar got smaller and did not fill the screen. I also had this bug in the older versions of Slax. I got rid of this problem by adding a new taskbar and remove the old one.

I believe yo ucan fix even those older problems.

Yurii LinuxUSER 2013-07-02 21:50

Hello! Thank you for your hard work. This is the best linux I've tried. Small size. My old PC just flies on this operating system. Beautiful KDE interface. Everything is easy and fast (unlike ubuntu). But of course, you need a lot more to do. For example, I do not have enough applications for the direct connect network (DC) and DLNA. I hope in the near future these applications will appear in the "Modules". Without these applications, I can not fully use my PC. So I still only test to your OS. But as I see it is a very promising Projects. I look forward to new updates. Thank you for your hard work.

parrothead 2013-07-03 00:28

Looks like something broke (at least for my setup) with wifi somewhere between 7.0.5 and 7.0.9beta. I haven't tried the intervening releases. Last night I downloaded the 32bit ZIP version of 7.0.9beta, verified the md5, and unziped and installed it to a flash drive that did not previously contain Slax. It booted up fine (chose X, without changes). I have a Linksys wireless N router using WPA (or maybe WPA2; not sure how to tell) encryption. Clicking on the network connections icon in the lower right, I could see my network and some of my neighbors. I selected mine and set up a connection ("system connection", "enterprise", and my passphrase). After a few seconds, I get a popup saying the network connection failed. Tried deleting and recreating several times, and various different settings with the same results. From a terminal window, I noticed dhcpcd and wpa_supplicant running, timestamped from when the system booted. From either /var/log/messges or /var/log/wpa_supplicant.log (forgot which), it looked like the system was briefly associated with the router, then disconnected with a message about "reason=3". (Going from memory here.)

I booted back to 6.1.2 (what I usually run on this laptop because I don't have new versions of all my modules) from a different flash drive, downloaded 7.0.5.zip, wiped out the Slax directory on the original flash drive and unzipped and installed 7.0.5 instead. When I booted to it, I could configure my network again.

I don't believe this is firmware or chipset related, because iwconfig showed my adapter in 7.0.9, and iwlist scanning returned various networks including my own. Seems I just couldn't connect to it.

Yurii LinuxUSER 2013-07-03 00:48

Yes, I have a problem with internet connection too. Is not connected to the wired Internet. Saying the network connection failed. Chip rtl8139

Alan Wilcox 2013-07-03 17:05

I am glad you are updating because the Help for all apps was not working for 7.08. These comments have been helpful and I will wait longer before trying 7.09b.

PS: I am new and had to make my own USB drive even though I bought one from you. Yours was read only. No new modules allowed.

Yurii LinuxUser 2013-07-03 21:15

Forgot to write that version Slax 7.0.8 network worked well, access to the internet was. But in version 7.0.9 does not connect to the network.

Ernesto Guerra 2013-07-04 00:40

Hey, when will we have an installer for Windows???

To Tui 2013-07-04 01:17

Hi,
The distro looks great, but I do not have a net! My internal wireless adapter is Broadcom 4313 802.11b/g/n
I download module 1662-b43-firmware.sb and put him in /slax/modules but wireless in network manager continues to be inactive.
My ISP is in WiMax and I have .deb and .rpm packages. Can I compile them for Slax?

z.trapl 2013-07-04 02:30

Also I can not connect to Wifi network.
Acer Extensa 5220
Wireless interface
product: AR242x / AR542x Wireless Network Adapter (PCI-Express)
vendor: Atheros Communications Inc.

parrothead 2013-07-04 03:07

I've tried wifi again with 7.0.9 without success. I've since downloaded 7.0.8 and can confirm that I can connect with 7.0.8 but not 7.0.9. This is a Toshiba laptop with Atheros AR242x / AR542x chipset, Linksys WRT120N wireless N router with v1.0.04 firmware, using WPA2 encryption.

I don't believe the problem is with the chipset or firmware, however. In 7.0.9, my wifi is detected and can see my own and other networks, just not connect. I believe the problem is with Network Manager. There are reports of a bug with an entry in /etc/NetworkManager/system-connections/* containing system-ca-certs=true. This is not in my connection file so this is not the problem for me. There were also older reports suggesting iwconfig wlan0 power off (turn off power management), but that does not work for me either (Operation not supported).

Darryl 2013-07-04 03:08

Cannot connect to internet - wireless. Worked in the previous version (7.0.8) on the same laptop.
Toshiba Satellite
Network adapter: Realtek RTL8191SE Wireless LAN 802.11n PCI-E NIC

Also is there an easy way to install a virtual keyboard for 64bit?

pistal 2013-07-04 03:54

Slax709-32bit : unable to connect to net. I have two wired ethernet card; system cannot determine correct card to internet (eth1). I have to kill dhcpcd for eth1 and run ifconfig for it.

Kim Johny 2013-07-04 21:37

Hello Thomas. I found out your Slax project very interesting. However I'm missing one important feature: I would like to start Slax with "Copy to RAM" option but with all settings saved in persistent mode. For example I would like to run it from RAM but with installed Firefox extensions and bookmarks which I set up previously during persistent session. Is it possible?

Luzius 2013-07-04 23:05

No net, no WIFI ! Is-it a self-defense feature against all this spying on the web ? Hmmm...

hamza rydhwan 2013-07-05 03:08

Best kde distro. but no wired. pc péntium4 1go ram . no forum? how connect a net.
best works. thanks. i m from algéria. excuse my inglish.

Igor 2013-07-05 22:26

Neat solution suggests itself: to include in the Slax alternative DE (RazorQT, E17, LXDE, etc). And separate cutlets from flies.

svily0 2013-07-06 07:54

For everyone with wi-fi not working problem, check what's in
/run/udev/firmware-missing
After grabbing the required firmware from the internet, place it in
/lib/firmware/where-appropriate/depending-on-the-driver ;)
Of course, this will only be persistent across reboots if you booted with slax.flags=perch while adding the firmware, and when you boot with the same option the next time.

Enjoy

Thanks Tomas, for the great tool!

burninbush 2013-07-07 10:27

Sad to report that 709b is also a non-starter here.

Have two desktops with AM2 cpus, and onboard Nvidia vga hardware. Slax will not complete the X phase of booting on either. That works OK on my laptop with Intel graphics.

Wired internet won't start on either desktop automatically -- but running ifconfig and dhcpcd will get them going. Wifi does not work (network manager seems broken.)

At that point, I toss another Slax cd into the wastebasket.

Mahmoud 2013-07-07 20:08

@burninbush

Now you know why I haven't updated since version 7.0.5.:-) Actually, I could have updated to 7.0.8. by now.

Tomas M 2013-07-08 06:50

Thank you very much for the tests and for bug reports. I will look into it and hopefully it will be better in final release.

Jayaram R Subramanian R 2013-07-08 12:48

After Ver 704, I never got proper display in my Acer 15" LCD monitor though I tried all the versions from 705 to 709 beta. probably because of incorrect screen resolution. The display is unreadable showing only coloured patches. How to adjust the screen resolution before booting Slax from CD? Pl help.

Антон Сазонов 2013-07-09 08:34

Tomas, why you won't use Stable End Of Line version of kernel at all ?..
.. or it's just Slackware dependence ?

Tomas M 2013-07-12 06:18

EOL means End Of Life, not end of line. Kernels marked as EOL are "dead" (no plan to maintain them in far future).

Michael Mendes 2013-07-13 17:31

Hi Tomas, i wanna give you congratulations for the great job you're doing. I love Slax and i can't live without a slax's pen drive. But the other reason that i'm writing here( I wanna apologise if it's not the right place, cuz i searched for the forum and the only one i found was about the Slax 6). I'm having 2 problems with slax. One is the size of taskbar, that always happend in my notebook(Samsung rv415, if that helps). The other i don't know if is slax's fault but, i'm a begginer in C/C++ and I create games in C++ with SDL, the game run fine but when I exit in fullscreen, the slax keep the resolution of the game. Those "problems" happen in Slax 7.0.8 and 7.0.9. I took a screenshot to show you(i think that helps). i'm sorry for my English cuz i'm from Brazil and i badly speak portuguese...
http://img203.imageshack.us/img203/5751/xvbv.png
http://img844.imageshack.us/img844/5875/82c6.png
Thanks very much for your time... :)

Curtis Pedersen 2013-07-15 19:07

Hi Tom
I got Slax 7.0.8 running on my Thinkpad T42 this evening. I even removed the solid state hard drive to see if Slax would run without it and to my amazement........................ It Actually Works !!!!!!!!!!

I love the design of the interface. Really clean and simple. I like how the unimportant stuff is simple and the processesing power is saved for the important stuff. I could not believe being able to play flash and mp4 videos ! - and with my harddrive removed and laying on the table !!! - I like how videos and windows go clear when you move them on the screen.

Only problem now is how to hook up USB Broadband Modem. I tried several moduels and activated them. I went to the Novatel website and they sugested Zenwalk Notes. I downloaded it and tried to install it but i'm not a brain surgen. Modem Model: Novatel Wireless Qualcomm 3G CDMA (if that means anything to you) - its the standard modem provided by my telephone company.

Maybe there is a way to grab a package from Ubuntu. Ubuntu recognizes the modem right away and i just click on provider name to connect.

Your Operating system has everything I have been looking for. Simple with NO CLUTTER and runs really fast because things are kept minimal. I treid damb small linux yesterday too and got that working but slax is way better.

I was not able to make the usb work right away. I tried clicking on that shell script thing that makes the usb bootable but the new Ubuntu I am using (13.04) said it did not recognize the file type. I don't like Ubuntu anymore. It has become a drunken orgy. I had to use Unetbooten to make the usb bootable. Then when i booted it up the boot stalled searching for /slax file so i rebooted back into ubuntu and draged the slax file onto the Usb. Anyway it works Awsome now. With the hard drive back in I was able to actually navigate to the hard drive directory and view its contents and open and view files - from Slax !!!!!!!!!!!

I cant wait to try the blender moduel tomorrow !!!!!

Amazing Work Tom !!!!!!!

I like my new operating system.

Please Keep it Simple - Don't let what happened to Ubuntu Happen To Slax !!!!!!!! I don't care about font shading and crap like that. Keep it clean. Keep it fast.

Your the BEST !!!!

Ricky Lachman 2013-07-18 00:20

I recently updated to slackware-current and noticed my networking was having issues under networkmanager/dhcp. I see a lot of comments regarding networking on this thread and I had issues with 7.0.9 beta myself.

For my slackware OS, my tagfiles had dhcpcd and did not include dhcp. I added dhcp and things seem to be back to normal. Not sure if I'm just seeing things, but I hope this helps.

Also, Tomas, I would love it if you would update:

http://ftp.slax.org/Slax-7.x-development/sources/Slax-7.0-sources/kernel/

Long live slax!

Antonio Olivares 2013-07-22 01:42

Slax 7.0.8 and Slax 7.0.9 beta don't work on a tricore amd with integrated nvidia graphics. The screen just turns black. The last one that worked fine was slax 7.0.5 which is the one that I have on my usb. I will send information upon your request of the system in question. Thanks Tomas for great work on Slax!

Adnan Shameem 2013-07-25 16:28

Hi Thomas.
I like Slax a lot. The best thing about it is I got to know about the coolness of KDE through Slax. Another thing is it also works just like desktop on my GMA3600 notebook (supports corner snapping, effects etc. while others don't support it or not so smooth.) And all this in just 215mb is just amazing.

I faced a problem with connecting to internet recently, with Slax. But found the solution: http://www.linuxforums.org/forum/networking/197380-zte-ac682-modem-connects-slax-but-cannot-browse.html

It seems that my USB modem did connect but without /etc/ppp/ip-up script I couldn't browse! It was such a strange problem! I think you know better, it is just a bash script that is executed after each successful connection by pppd. It was missing from Slax installation. I copied it from my Xubuntu 12.04 installation. I also copied (just in case) ip-up.d directory, ip-down, ip-down.d directory and made each file executable. Then it worked fine.

There are also ipv6-up, ipv6-up.d, ipv6-down, ipv6-down.d. But I didn't care for them.

If I am a single person saying that I had a problem, so I bet there are many others who faced the same problem due to the missing files. Please include them in the next release!

Владимир Ворошилов 2013-07-29 21:54

Hi,
i want to say many thanks for so linux distribution. And let's wish many years of distribution and support.

Владимир Ворошилов 2013-07-29 22:02

And one more thing. Registration on slax forum is real pain in ass. Who nows, is the timeout in register.php or wrong captcha (easy reading by bot, not human)

Mahmoud 2013-08-08 21:17

Hi Tomas,

When do you think that the final version of 7.0.9. will be ready?

Mahendra Tallur 2013-08-15 07:31

Hi Tomas !

Do you mind if I post a request here, as it seems there is no support forum available ?

Is there any way to install the nvidia proprietary drivers ? It's extremely important as Nouveau is far from supporting everything properly. I have a big performance drop here as well as overheating.

Apart from that, I managed to revive an eeePC that felt desperately slow under any other distro I tried, including XFCE ones. Which is pretty impressive as KDE is supposed to be the most resource hungry :-) Thanks a lot !

jcsoh 2013-08-15 22:41

" there is no support forum available ?"
http://old.slax.org/forum.php

Tommi Uimonen 2013-08-27 06:13

Hello, installing to hard drive in vmware does not boot slax due to a bug in syslinux (fix released in syslinux 6.0.1).

jsanchezgksk@gmail.com 2013-09-09 09:37

how know if my own module sb is working i have slax 7.0.8
thanks

Tozé Almeida 2013-09-21 10:27

Hello. I´ve slax 7.0.9 running in a usb stick. It runs good but after some times, slax wont boot anymore. It plays the start music, the mouse is in the screen and some notification also apears, but the screen stays black and i cant do anything. Seems like the desktop wont run.
I never remove the usb stick when computer is on.
How can i solve this problem?

Tozé Almeida 2013-09-25 16:52

Hello. The version that i have is 7.0.8 and not 7.0.9.

jcsoh 2013-09-25 18:45

@ Toze
The last official release of slax is still version 7.08, so if you download from the slax's download section , you will only get slax 7.08.

To get slax 7.09 , look at Tomas post , the 1st post on this page . The download links to slax 7.09 beta is given in his post.

Tozé Almeida 2013-10-02 19:07

Hello. I've downloaded 7.08 and 7.09 but the problem still the same. The first boot its OK but the second not. I descovered that the problem is "permanent changes" because if i delete the save.dat, slax boot again normaly. Now i will try an older version that i think dont have this problem. There is a way to solve the problem in version 7?

jcsoh 2013-10-04 00:46

@ Toze
Is your thumdrive large enough in term of size capacity ?.
Overtime as slax save to the changes.dat file , the file get larger.
It the thumdrive run out of space , then you get errors.

Tozé Almeida 2013-10-05 18:36

Hello. I'm sorry for my bad english, but i will try to explain. Yes, i've tried with 2 usb drives but the problem is the same. One of 2GB and one of 4GB. If i boot once with permanent changes and restart, the second time doesnt boot anymore. I've seen posts of this problem from 4 years ago.

Amir Khosro 2013-10-07 11:54

hi , a hard drive installer needed in last version
I think a little larger slax is not matter , I cant install slax 7.0.8 in my laptop hard drive with windows7
finally QGIS 1.8 , Can I install it ?
, I am weak in Linux , and from iran . . .

jcsoh 2013-10-10 03:27

@ Toze , I believe a 2gb thumb drive is too small as slax's changes.dat can easily grow to a few gb . Perhaps you can try a 8gb thumbdrive .

"I've seen posts of this problem from 4 years ago." .

By this you imply the problem is left unresolved ? But you have to remember , if Tomas can' t replicate the problem , then to him there is no problem.

Some issue other than this , for eg claim by more than one users that the installer script cannot run . Yes , the complaint appear again and again, but for every one use that it didn't work , for how many did it work ?.

Same in your case . Too some extend you imply this problem is unresolved for years , but what if I throw back the question to you.

How many users are running slax on usb sucessfully and saving their changes ? . This is what slax is design for , so I would say if for the last 4 years if it didn't work , then slax may as well close up and terminate the project.

I don't know why it did work for you , but until proven otherwise , I have no reason to think it didn't work for most of the other users.

Slax is not the issue . Your hardware or your system , or your mixes of modules (you are suppose to test with a clean system ie with no extra modules) or even the os /method you use to make the usb thumbdrive may have a part in the problem.

Tozé Almeida 2013-10-12 17:18

Hello jcson. I think slax is great but this little problem is a pain for me.

I post here to find if someone have the same problem and how to solve it. I know that the version 6.XX this doesn´t happen, only in 7.XX. The changes.dat only have 5MB, then the problem isn´t the space available.

I do the instal, formating the usb and copy the slax files to there... Is better to use unetbootin?

I will see for the modules that i have, and try to find the problem.

Aleksandr SAnTAN.M 2013-12-20 03:16

Hello, it is greate that SLAX alive and I start testing new version. So I have several questions, but first of all let me explain my situation. I build small live USB with slightly changed SLAX distro for public kiosk. Repacked core and xorg with a couple of my own binaries and bash scripts and modified syslinux.cfg for booting "xorg" and "toram" without boot menu. But i want some security and beauty.
1) Is it possible to store all SLAX data in encrypted file or partition? Of cource I understand that boot folder or partition must be unenctypted.
2) Is it possible to apply any custom boot screen image to SLAX, may be witout progress bar or animation? Maybe Plymouth or Splashy or something else?
I'll appriciate any howtos or suggestions.

Aleksandr SAnTAN.M 2013-12-20 03:25

Hello Tozé did you try to format flash drive in ext2 2or ext3 file system?

Dery Gadhol 2014-01-12 22:24

Wow

zc x 2014-01-29 23:05

Hi, everyone.
@Tozé Almeida
I guess you are not alone. I encouter the same problem as you do. I checked /var/log/message, possibly the problem is caused by certain wrong configs of plasma-desktop. I may post later if I find more.
While the screen turns black and you can only find your cursor, try ctrl + F2. This will pop a run-program window on the top. You can try konsole or dolphin or any other command you know.

zc x 2014-01-29 23:13

Oops, the run-program window shortcut should be alt + F2.

zc x 2014-01-30 01:04

My ideas about Tozé Almeida's question:
I can confirm there is something wrong with the configure files of plasma-desktop. On my machine, any changes made to panel will cause the plasma-desktop to crash. If there is no such a process called plasma-desktop running properly in KDE, you certainly cannot see your desktop.

My solution is: DO NOT make any modifications to your desktop(Lauchers, icons, layouts, etc.) when plasma-desktop is working properly. Let everything remain the same as it is.

Some details:
# cat /var/log/message | grep plasma
Jan 30 13:42:47 slax kernel: plasma-desktop[2709]: segfault at 4c ip b41c4313 sp bfcf2e20 error 4 in libQtDeclarative.so.4.8.4[b40be000+24f000]
Jan 30 13:43:49 slax kernel: plasma-desktop[2776]: segfault at 89 ip b4181313 sp bfdc1a90 error 4 in libQtDeclarative.so.4.8.4[b407b000+24f000]
Jan 30 13:47:53 slax kernel: plasma-desktop[2845]: segfault at 17e ip b4100313 sp bfb94d40 error 4 in libQtDeclarative.so.4.8.4[b3ffa000+24f000]
Jan 30 13:48:45 slax kernel: plasma-desktop[2869]: segfault at 1b2 ip b4100313 sp bfb94d40 error 4 in libQtDeclarative.so.4.8.4[b3ffa000+24f000]
Jan 30 13:51:20 slax kernel: plasma-desktop[2920]: segfault at 24d ip b41ad313 sp bf8bf200 error 4 in libQtDeclarative.so.4.8.4[b40a7000+24f000]
Jan 30 13:51:50 slax kernel: plasma-desktop[2948]: segfault at 26b ip b4178313 sp bff49e30 error 4 in libQtDeclarative.so.4.8.4[b4072000+24f000]
Jan 30 14:09:33 slax kernel: plasma-desktop[2672]: segfault at 4a ip b419c313 sp bf8f5c50 error 4 in libQtDeclarative.so.4.8.4[b4096000+24f000]

What's more, if I run something like
kdeinit4 plasma-desktop
OR
plasma-desktop
I can find the task-bar (panel) appear and then vannish, with a new error statement about plasma-desktop added in /var/log/message.

Eduardo Gomes 2014-02-18 17:24

Add vlc media player in new version please. Thanks

Sonjay Or 2014-03-18 21:17

YES!
WE NEED VLC MP!

THANKS!