02

January
2019

Releasing Slax 9.6.6

Good news everybody, yet even better Slax has been released :) This version adds forgotten intel graphics drivers and introduces the possibility to disable automounting of disk drives by a boot parameter.

All the orders made during holidays were processed today, and they contain this new Slax version preinstalled. Thank you for your patience, it was worth it :)

Enjoy the new release, and happy new year!

User comments
lucbertz 2019-01-03 10:35

Home page is still reporting 9.6.5 version download links.

Anyway 9.6.6 version is available if you modify "9.6.5" to "9.6.6" text:
http://ftp.sh.cvut.cz/slax/Slax-9.x/slax-32bit-9.6.6.iso
http://ftp.sh.cvut.cz/slax/Slax-9.x/slax-64bit-9.6.6.iso

Tomas M 2019-01-03 12:07

Thank you very much for notice, I've updated it now.

Ivo Giulio Gagliolo 2019-01-04 08:13

Hello Tomas,
I must, one again thank you for your work.
I'm considering using your Slax on newer PCs other then the old ones...
the reliability of your system is superior to some "mainstream" linux...

@Ivo Giulio Gagliolo
regarding xorg drivers, I'll have to add the forgotten intel xorg drivers to slax, please wait for new release. I'm not sure why you need startx manually, this is strange.

today I'll try out the integrated intel.xorg driver, maybe the "manually startX" error won't show up.

@Ivo Giulio Gagliolo
Regarding problems with core.sb module, please try dmesg to see error messages reported by kernel, maybe there will be some hint.

I'll try dmesg... I hope it is not an hardware issue...

Tks again

Ivo

T_L 2019-01-04 15:03

Hi, I'd like to unsubscribe this account Slax website and subscribe with a new one, where is it on the website ? Thanks for answers. TL

my9823 2019-01-08 15:19

how to input chinese?

C 2019-01-09 02:59

Thank you for making this wonderful distribution. Unfortunately, with a brand new Thinkpad X1 Carbon (6g) many of the drivers were not configured so that: Laptop brightness was not adjustable, and various power settings didn't seem to be installed. Since this is a very popular laptop model do you think you would be willing to support this one in any fresh Slax image? Or do you at least have advice about what to install to make everything work? Is there a database of laptop model to apt packages we could look at?

Corvin 2019-01-09 12:38

Hi, I found one very little glitch with 9.6.4 and 9.6.5 which is easly fixable. The hostname in /etc/hostname is set to slax, but it is set to debian in /etc/hosts. This prevents for example collectd to install properly. I am not sure if it is fixed with the newest version, but if no - please fix.

lucbertz 2019-01-09 16:59

I'd like to see a parallel release of Slax based on Debian Testing (or at least Ubuntu semestral release) in order to get a more recent kernel (better support for newer hardware) and up-to-date software packages.

Gianluca 2019-01-10 11:08

Hello,
I just received the usb-microsd and it contains 9.6.5
Is there a simple method to update to 9.6.6? Or to put-in a suitable intel_drv.so file?
It would be nice to also have qxl_drv.so between the Xorg drivers
Another thing: it seems that on 9.6.5 the "text" cheat code doesn't work. To start in text mode I verified it works instead adding the "3" for run level at the end of boot line
Keep on with the good job!

Alperen Yavuz 2019-01-12 20:23

Geliştirici olmak istiyorum bilgim az ama yararlı olacağımı düşünüyorum :)

Dr. Csatlócki István 2019-01-13 01:47

Köszönöm szépen a befogadást!
It's works with systemd on UEFI and GPT !!!!
https://www.facebook.com/100009836910394/videos/801887480149142/
https://prohardver.hu/tema/linux_abszolut_kezdoknek/hsz_65250-65250.html

Tomarrow i'll write the items!

It's simple ...... systemd !!! ;)

Good night ewerybodi !

Dr. Csatlócki István 2019-01-13 11:05

My blog about systemd boot of slax:

https://logout.hu/blog/csixy/index.html

Best Regards !

Вячеслав Волошин 2019-01-13 12:10

Modules created by me, applications in the form Appimages and Portable Apps:

https://drive.google.com/drive/folders/1vnpx0G6RcoP32cHlrbXmODYdbUuQhpft?usp=sharing

Use, on health! :)

Tester 2019-01-14 07:08

Hello Tomas,
i found; u recoded dir2sb command but something is wrong i guess.

before when i use the command "dir2sb new new.sb" it was making sb file under the folder named as "new"

as of now the command is making sb file with folder named as "new". i mean "new" folder is turning as sb file.

question: how can i make sb file under new folder. not the include the folder "new".

thanks

Вячеслав Волошин 2019-01-14 08:41

@ Tester
Use a copy of the folder, anywhere.

Dr. Csatlócki István 2019-01-17 21:17

Nice work! I like this. It's good to work with its. Is there anyone else who is using it on UEFI machine?
https://prohardver.hu/tema/re_csixy_kalandom_a_slax_linux-szal_mukodik_gpt_pa/hsz_8-8.html

Вячеслав Волошин 2019-01-18 02:12

Hello Tomas,
I would like to see in the new version, if possible:
1. Bluetooth support, the ability to transfer sound to headphones.
2. Python 3.5, I need it for new versions of programs, in particular, zim.
3. You can add to the exit menu: systemctl suspend. It works, and I use it often.
Successes in the development of the distribution kit!

Dr. Csatlócki István 2019-01-18 15:50

Here is my modified slax9.6.6_64bit.iso:
https://skamilinux.hu/phpBB3/viewtopic.php?f=7&t=576&p=7522#p7522

Lukas Veselovsky 2019-01-18 17:33

hi tomas,

is posible add to initrd a emmc storage driver? (some netbooks have emmc drive)

and to system add mpg123

does Slax have a pm-utils for suspend,hibernate ?

Dr. Csatlócki István 2019-01-19 00:37

@ Вячеслав Волошин 2019-01-18 02:12

If you install a synaptic, python 3.5 will also be due to dependencies.

Вячеслав Волошин 2019-01-19 00:47

@ Dr. Csatlócki István

#apt install python3.5
...
The following packages have unmet dependencies:
python3.5 : Depends: libpython3.5-stdlib (= 3.5.3-1+deb9u1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Вячеслав Волошин 2019-01-19 00:50

@ Lukas Veselovsky

systemctl --help

Вячеслав Волошин 2019-01-19 00:52

@ Lukas Veselovsky

mpg123 module - https://drive.google.com/drive/folders/1vnpx0G6RcoP32cHlrbXmODYdbUuQhpft?usp=sharing

Вячеслав Волошин 2019-01-19 01:39

@ Dr. Csatlócki István
I fixed the broken package, made the python3.5 module, but further, when launching a new zim version:
ImportError: No module named 'gi'
Python for me is a dark forest! :)

Tomas M 2019-01-19 08:55

@Corvin
thanks, I will fix /etc/hosts in next release

@lucbertz
good idea, if there is sufficient amount of patrons, I can do that

@Gianluca
you can update Slax easily, simply download new version, and unpack it from ISO file directly to your USB device, that should be sufficient.

@Tester
rename your directory 'new' into 'new.sb' and then use dir2sb new.sb

@Вячеслав Волошин
Thank you for suggestions.
Regarding python3.5, simply use apt install python3.5 and it works. I just tested with newest Slax version.

@Lukas Veselovsky
I'm not sure how to add emmc storage driver. What kernel modules are needed?
pm-utils will be added in next Slax release
I was told following command should be used for suspend: systemctl suspend

Lukas Veselovsky 2019-01-19 13:12

i am not sure that is this resolve problem with emmc boot but i find this info about module needed for boot from emmc ssd storage

root@slax:~# modinfo mmc_block
filename: /lib/modules/4.9.0-8-amd64/kernel/drivers/mmc/card/mmc_block.ko
description: Multimedia Card (MMC) block device driver
license: GPL
alias: mmc:block
depends: mmc_core
retpoline: Y
intree: Y
vermagic: 4.9.0-8-amd64 SMP mod_unload modversions
parm: perdev_minors:Minors numbers to allocate per device (int)
root@slax:~#

slax contain this module, i boot slax on normal pc, but on netbook doesnt find slax data

ryan_fu 2019-01-19 15:17

@Lukas Veselovsky
mmc_block module not right. if supoort ssd, you need nvme module. I've tried to add nvme module, and can use fdisk command show my ssd disk. but it can not find slax folder on it when system boot. I guess it maybe something wrong about "blkid", because it can not show ssd disk when I use "blkid" command, .and this command is used to guess slax folder on which disk in live-script, so if it can not find right disk, system is break.
BTW, I tried to use other release version of blkid, it seems can't be work if replace in initrfs.img. This blkid seems be compiled by Tomas self.

Greg Chao-Kuei Hung 2019-01-19 15:23

Hi, did anybody try manually modifying /root/.fluxbox/menu ? Tomas said I was looking at the right file. However, I tried adding an entry, deleting an entry, or swapping the names of two entries in that file. Nothing has any effect at all. (Of course after every change I logged out, login again, and startx)

I am using slax-32bit-9.6.6.iso but I don't think 32bit is the problem.

Lukas Veselovsky 2019-01-19 15:49

ok, now it works! i boot slax from internal emmc storage.

i copy whole folder with modules of mmc to initrfs.img and very important is edit modules.dep and add this info about this modules. slax dont have depmod command.

very nice now i have slax installed in asus vivobook e12 203na its nice distro and i love xlunch combination with flux.

and i have partitioning my mmc:
fdisk -l

Disk /dev/mmcblk0: 29.1 GiB, 31268536320 bytes, 61071360 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 5255B2F3-4143-4861-B787-CF2F38099589

Device Start End Sectors Size Type
/dev/mmcblk0p1 2048 2099199 2097152 1G EFI System
/dev/mmcblk0p2 2099200 61069311 58970112 28.1G Linux filesystem

i put slax folder and EFI folder to the some EFI part created with GParted with esp,boot info, another partition i have for DATA

root@slax:~# ls /media/mmcblk0p1/
EFI slax

i use syslinux not grub2

lot of thx

Lukas Veselovsky 2019-01-19 16:13

i have still problem to boot on my netbook. combination of sdcard and emmc is ok

Вячеслав Волошин 2019-01-20 08:49

@ Greg Chao-Kuei Hung
Check /root/.fluxbox/init & /etc/X11/fluxbox/init:

session.menuFile: ~/.fluxbox/menu

Copy /etc/X11/fluxbox/fluxbox-menu to ~/.fluxbox/menu, then edit

Greg Chao-Kuei Hung 2019-01-20 15:17

Ah! Thank you, Tomas and Вячеслав Волошин. I suddenly realized that when you right click in the background, you can bring up the menu defined in ~/.fluxbox/menu , and you don't even have to logout after editing it.

What I incorrectly referred to as the menu that never changed, is the icon in the lower left corner. What is it called and how can I change its contents? I see that it is updated automatically after I installed software (for example geany and dillo). However I would like to manually add things like sakura and gcin-tools there. What file(s) should I edit? Thanks!

ryan_fu 2019-01-21 01:54

@Lukas Veselovsky
if your laptop computer uses ssd disk, it need nvme module, not mmc module.

Tomas M 2019-01-21 12:21

@Greg Chao-Kuei Hung
Icons you see after clicking the bottom-left button (or press Alt+F2) are displayed by xLunch launcher. It scans /usr/share/applications and parses *.desktop files there. If you wish to add item, create a new file like /usr/share/applications/newapp.desktop and xlunch will detect it automatically. If you need to reorder items, you need to reorder the file names, currently it sorts them alphabetically.

@Lukas Veselovsky
I prefer not to add the whole mmc directory (from /lib/modules/...) to initrd. Can you suggest particular module files (.ko) to add to make it work?

Greg Chao-Kuei Hung 2019-01-22 13:04

@my9823
You can look at my blog post: https://newtoypia.blogspot.com/2019/01/slax.html
I only manage to make gcin input work in the sakura terminal.
Other apps can only show Chinese but not input Chinese. (You can copy paste, though.)

@Tomas
Can I mount the secure traveler usb from my desktop computer?
For example if I wish to copy my modules into the usb?